Usas y tienes....

Sign by Danasoft - For Backgrounds and Layouts

23/11/10

Aumento de velocidad "milagroso" en ubuntu 10.10 maverick

Hace unos días hubo una noticia bastante buena para la comunidad linux, han creado un parche que aumenta el rendimiento de linux de manera espectacular, sobre todo en multitarea.Y como digo yo, ya que para mi gusto iba bastante bien, imaginaos si aplicamos este simple parche.
En un linux normal son 200 líneas, pero en ubuntu la cosa es más simple, con 4 líneas basta.
Lo he comprobado en varios equipos, donde más se nota es en el equipo de 4 núcleos.

Realizamos lo siguiente:
$ sudo su
$ mkdir -p /dev/cgroup/cpu
$ mount -t cgroup cgroup /dev/cgroup/cpu -o cpu
$ mkdir -m 0777 /dev/cgroup/cpu/user
$ echo "/usr/local/sbin/cgroup_clean" > /dev/cgroup/cpu/release_agent
Le damos permisos:
$ chmod +x /etc/rc.local
Editamos el ~/.bashrc:
$ gedit ~/.bashrc
Pegamos el siguiente código al final del archivo de texto:

if [ "$PS1" ] ;
then mkdir -m 0700 /dev/cgroup/cpu/user/$
echo $ > /dev/cgroup/cpu/user/$/tasks
echo "1" > /dev/cgroup/cpu/user/$/notify_on_release
fi
Guardamos el archivo.
Modificamos el cgroup_clean:

$ gedit /usr/local/sbin/cgroup_clean
Pegamos el siguiente código al final del archivo de texto:

#!/bin/sh
rmdir /dev/cgroup/cpu/$*

Guardamos y le damos permisos:
$ sudo chmod +x /usr/local/sbin/cgroup_clean

Reiniciamos y a ver los resultados.

Ver Plymouth Ubuntu 10.10 Maverick Meerkat con tarjetas Nvidia o ATI(arranque feo) o quitarlo y ver sólo consola al arrancar

En la nueva versión de ubuntu en este caso la 10.10, una vez instalado nuestro linux, instalaremos los drivers de ati o nvidia, dependiendo de la gráfica que tengamos, pero una vez instalado, tendremos un pequeño inconveniente:
En el arranque cuando pone tan bonito ubuntu con sus bolitas debajo desaparece, y sale ubuntu 10.10 cuadriculado y feo al arrancar.
Es un error de plymouth, es este post se explicara con solucionar este problema, aunque es un fallo estético más que otra cosa, por lo tanto si no se hace, no pasa ni tampoco nada.
Ubuntu con plymouth en bonito

Estos son los pasos a seguir:
-Instalamos lo siguiente:
$ sudo apt-get install v86d hwinfo
$ sudo hwinfo --framebuffer
-Nos saldrá algo así:

Tenemos que elegir la resolución que queramos para el inicio de ubuntu, se recomienda 1024x768 si tenemos un monitor de 4:3.Yo le puse 1280x1024 ya que es la resolución de mi monitor.
-Editamos el archivo de configuración de grub:
$ sudo gedit /etc/default/grub
Y sustituimos la línea  GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash” por lo siguiente:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x1024-24,mtrr=3,scroll=ywrap"
Quitamos # de la línea #GRUB_GFXMODE
Y ponemos lo siguiente:
GRUB_GFXMODE=1280x1024
Guardamos el archivo.
Editamos otro fichero:
$ sudo gedit /etc/initramfs-tools/modules
Y ponemos la final del archivo:
uvesafb mode_option=1280x1024-24 mtrr=3 scroll=ywrap
Lo guardamos.
Ejecutamos lo siguiente:
$ echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
$ sudo update-grub
$ sudo update-initramfs -u

Ya está listo para que se vea bien.

Eliminar inicio con plymouth
Si lo que queremos es justo lo contrario, que no se vea plymouth, y salga la consola cuando carga ubuntu, se que es un poco friki, pero a veces también queda bien, hacemos los siguiente:

Por consola introducimos lo siguiente:

$ sudo gedit /etc/default/grub

Las líneas siguientes las dejamos como están debajo, sin nada después del =:

GRUB_CMDLINE_LINUX_DEFAULT=
GRUB_CMDLINE_LINUX=

Guardamos el archivo e introducimos lo siguiente:
$ sudo update-grub
Ya lo tendremos en modo texto.

3/11/10

Realtek 8187L funcionando modo monitor y normal en ubuntu 10.10 (Alfa 1W AWUS036H)

  

Actualización 20-9-2011
Ya funciona de forma más simple y sin problemas, entra aquí y sigue el manual
Existen una familia de adaptadores wifi bastantes potentes con los cuáles la potencia de estos adaptadores podremos llegar más alla para nuestra cobertura de wifi en nuestros ordenadores.
En este caso yo dispongo de una antena alfa 1W con la cuál la cobertura wifi se aumenta bastante.

Hay un problema en ubuntu, el modulo que viene en el kernel es inestable, y al principio conecta y se puede navegar correctamente, pero al tiempo deja de funcionar correctamente.
Para ello no nos queda mas remedio que instalar el correspondiente módulo de kernel con su parche, para que funcione correctamente y además la podamos poner en modo monitor correctamente.
En este caso el chip es un RTL 8187L, por lo cuál este módulo de kernel sirve para cualquier adaptador wifi que tenga este chip.
Si no se tiene este chip no nos sirve para nada realizar lo explicado a continuación.
Para saber si tenemos un RTL 8187L en USB introducimos lo siguiente por consola y nos aparecerá algo parcedo a esto:
$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Para instalarlo introducimos por consola lo siguiente:

$sudo su
$dpkg --configure -a && sudo apt-get install -f && sudo apt-get update
$sudo apt-get install linux-headers-$(uname -r) build-essential make patch gettext gcc python-psyco autoconf subversion
$sudo apt-get install tcl8.5 openssl libssl-dev libnl1 libnl-dev cracklib-runtime python-scapy macchanger-gtk xterm iproute
$apt-get install build-essential subversion module-assistant
$module-assistant prepare
$sudo rmmod r8187 rtl8187 mac80211 cfg80211
$sudo mkdir /usr/src/drivers
$cd /usr/src/drivers 
$sudo wget http://dl.aircrack-ng.org/drivers/rtl8187_linux_26.1010.zip
$sudo unzip rtl8187_linux_26.1010.zip 
$cd rtl8187_linux_26.1010.0622.2006/ 
$sudo wget http://patches.aircrack-ng.org/rtl8187_2.6.35-monitor_only.patch 
$sudo tar xzf drv.tar.gz 
$sudo tar xzf stack.tar.gz 
$sudo patch -Np1 -i rtl8187_2.6.35-monitor_only.patch 
$sudo make 
$sudo make install
Y luego para activarlo:
sudo modprobe r8187
Recomiendo reiniciar el equipo después para que funcione correctamente.
Ya lo tendremos instalado correctamente.

Actualización 20-9-2011
Ya funciona de forma más simple y sin problemas:
http://linuxkillwin.blogspot.com/2011/09/realtek-8187l-en-ubuntu-funcionando-sin.html