Usas y tienes....

20/9/11

Realtek 8187L en ubuntu funcionando sin fallos por fin!!! (Alfa 1W AWUS036H)

Ha sido un largo camino, varios años detrás de esta tarjeta la cuál no se llevaba bien con ubuntu.
He conseguido que funcione en ubuntu, es simple, y sirve para cualquier versión de ubuntu.
Introduce lo siguiente por consola:
-Metemos en lista negra los módulos que viene por defecto en ubuntu: 
$ sudo rmmod r8187 rtl8187 mac80211 cfg80211
-Descargamos en paquete:
$ wget http://dl.dropbox.com/u/199307/rtl8187L_linux_26.1040.0820.2010.release.tar.gz
-Lo descomprimimos: 
$ tar xzf rtl8187L_linux_26.1040.0820.2010.release.tar.gz
$ cd rtl8187L_linux_26.1040.0820.2010.release/
-Lo instalamos 
$ make
$ sudo make install
 
Ahora quita el adaptador del equipo y vuélvelo a poner.
 
Parece sencillo pero funciona. 

Actualización para ubuntu 12.10: es posible que sea necesario realizar lo anteriormente explicado en este post, link del post actulizado.

Fuente: linuxkillwin.tk

Artículos Relacionados



9 comentarios:

  1. Funciona con ubuntu 11.04 porque me manda este error:

    make[2]: se sale del directorio «/usr/src/linux-headers-2.6.38-8-generic»
    find /lib/modules/2.6.38-8-generic -name "r8187.ko" -exec ls -l {} \;
    find /lib/modules/2.6.38-8-generic -name "r8187.ko" -exec rm {} \;
    install -p -m 644 r8187l.ko /lib/modules/2.6.38-8-generic/kernel/drivers/net/wireless
    depmod -a
    make[1]: *** [install] Error del bus (core dumped) [Núcleo vaciado a un archivo]
    make[1]: se sale del directorio «/home/ubuntu/rtl8187L_linux_26.1040.0820.2010.release/rtl8187»
    make: *** [install] Error 2
    ubuntu@ubuntu:~/rtl8187L_linux_26.1040.0820.2010.release$ sudo make install
    kernel/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko: kernel/net/mac80211/mac80211.ko kernel/net/wireless/cfg80211.ko kernel/drivers/misc/eeprom/eeprom_93cx6.ko
    kernel/drivers/net/wireless/rtl818x/rtl8187/rtl8187.ko: kernel/net/mac80211/mac80211.ko kernel/net/wireless/cfg80211.ko kernel/drivers/misc/eeprom/eeprom_93cx6.ko
    make[1]: se ingresa al directorio «/home/ubuntu/rtl8187L_linux_26.1040.0820.2010.release/rtl8187»
    make -C /lib/modules/2.6.38-8-generic/build M=/home/ubuntu/rtl8187L_linux_26.1040.0820.2010.release/rtl8187 CC=gcc modules
    make[2]: se ingresa al directorio «/usr/src/linux-headers-2.6.38-8-generic»
    Building modules, stage 2.
    MODPOST 1 modules
    make[2]: se sale del directorio «/usr/src/linux-headers-2.6.38-8-generic»
    find /lib/modules/2.6.38-8-generic -name "r8187.ko" -exec ls -l {} \;
    find /lib/modules/2.6.38-8-generic -name "r8187.ko" -exec rm {} \;
    install -p -m 644 r8187l.ko /lib/modules/2.6.38-8-generic/kernel/drivers/net/wireless
    depmod -a
    make[1]: *** [install] Error del bus (core dumped) [Núcleo vaciado a un archivo]
    make[1]: se sale del directorio «/home/ubuntu/rtl8187L_linux_26.1040.0820.2010.release/rtl8187»
    make: *** [install] Error 2

    ResponderEliminar
  2. Mejor bajar antes el fichero (con wget) y luego hacer el rmmod, sino, puede que la tarjeta que en ese momento estás usando bloquee el borrado de algunos módulos, o peor, que luego el wget no funcione pues la tarjeta que usabas (si es wifi) ya no lo haga, y te quedas sin conexión.

    ResponderEliminar
  3. eres un crack, estaba mas de 1 a;o con el problema, incluso deje ubuntu, muy agradecido.

    ResponderEliminar
  4. Tengo el mismo problema que el anonimo que le da error. me desespara estooo. Que puedo hacer?

    ResponderEliminar
  5. tambien me sale error

    ResponderEliminar
  6. me da ERROR:


    /home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.c:151:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl8187_usb_disconnect’
    /home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.c:164:12: error: ‘rtl8187_usb_probe’ undeclared here (not in a function)
    /home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.c:165:16: error: ‘rtl8187_usb_disconnect’ undeclared here (not in a function)
    /home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.c:3755:22: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl8187_usb_probe’
    /home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.c:3855:23: error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ‘rtl8187_usb_disconnect’
    /home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.c:3151:33: warning: ‘rtl8180_stats’ defined but not used [-Wunused-function]
    /home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.c:3357:13: warning: ‘r8180_set_multicast’ defined but not used [-Wunused-function]
    make[2]: *** [/home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187/r8187_core.o] Error 1
    make[1]: *** [_module_/home/g/rtl8187L_linux_26.1040.0820.2010.release/rtl8187] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-3.8.0-19-generic'
    make: *** [all] Error 2

    ResponderEliminar
  7. Me sale el mismo error que al compañero anterior. Por favor, ayuda!!

    ResponderEliminar
  8. sale error saca la solucion por favor

    ResponderEliminar